Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


login redirects to discussions index but does not log me in

edited October 2006 in Questions
I've been having this problem since I installed it. Sometimes I have to go through sign in like 10 times to get it to finally sign me in. I searched through the forum but didn't find anything on this, sorry if I inadvertently double posted. Thanks, Jeff

Comments

  • Make sure the domain you're accessing the login page from is the same as the cookie domain (eg. if the cookie domain is 127.0.0.1, access it via 127.0.0.1 and not something like localhost).
  • well the domain is my regular domain and i'm only accessing it through that domain so I don't think that is it...

    here is a link to my installation in case anyone wants to see if they can recreate it.

    login: demo
    pass: pass
  • That is weird. It only seems to work when I check the 'remember me' button. Maybe something screwed up with your server's session handling?
  • yeah, i dunno... it's an IIS server, dunno if that makes a difference. I have like a half dozen asp.net apps running on there that use sessions with no problems though
  • I must be a session problem. Check the error log and your session settings.
  • edited October 2006
    All the cookie stuff seems to be working fine now:

    Set-Cookie: PHPSESSID=2314a9286e9e939cf2e438f41b903c1a; path=/
    Expires: Thu, 19 Nov 1981 08:52:00 GMT

    I am of course first-time browsing this page with a clean browser (firefox).

    This would seem to imply that your browser has some bad cookies or something. I'd suggest clening out your cookies n stuff.

    I was able to sign in and out several times using the demo login
  • I deleted all my cookies; I still can't sign-in, with-out the remember options on.
  • There's nothing in the error log or anything out of the ordinary with the session settings. I'm going to upgrade my version of php and see if that has something to do with it. the server still had version 4, I guess we'll see if upgrading to version 5 makes any difference.
  • ok i poked around a bit and found some differences:

    Yours:

    Response Headers - http://www.skatemag.com/vanilla/index.php

    Connection: close
    Date: Sun, 15 Oct 2006 23:07:10 GMT
    Server: Microsoft-IIS/6.0
    X-Powered-By: ASP.NET, PHP/5.0.4
    Last-Modified: Sun, 15 Oct 2006 23:07:09 GMT
    Content-Type: text/html; charset=utf-8
    Set-Cookie: PHPSESSID=9999e8dfaa2236f1661d128e03e13b81; path=/
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache

    200 OK


    Lussumo:
    Response Headers - http://lussumo.com/community/

    Date: Sun, 15 Oct 2006 23:08:20 GMT
    Server: Apache/2.0.52 (Red Hat)
    X-Powered-By: PHP/4.3.9
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Last-Modified: Sun, 15 Oct 2006 23:08:20 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Connection: close
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=utf-8

    200 OK


    My home test:
    Response Headers - http://192.168.0.5/~ReDuX/forum/

    Date: Sun, 15 Oct 2006 23:08:58 GMT
    Server: Apache/1.3.33 (Darwin) PHP/4.3.11
    X-Powered-By: PHP/4.3.11
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Last-Modified: Sun, 15 Oct 2006 23:08:58 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Keep-Alive: timeout=15, max=98
    Connection: Keep-Alive
    Transfer-Encoding: chunked
    Content-Type: text/html; charset=utf-8

    200 OK


    Perhaps has something to do with you running PHP 5 ? ( i dont know if vanilla is 100% compatible with php 5 yet, or even if php5 is finalised (standardised etc.))

    Note that yours has a php session id and path. the others dont. not even lussumo.
    Perhaps something relating to the cookie lacking a more specific path than \ , im not sure.

    I'd certainly move to a more stable php version (4.3.x) though.

    hope that sheds some light on the subject.
  • that's weird.. i didn't think i was on php5 on that server?
  • edited October 2006
    yep, Microsoft Windows Internet Information Server with PHP5:

    Server: Microsoft-IIS/6.0
    X-Powered-By: ASP.NET, PHP/5.0.4
  • i guess i am... but man how freaking long is php5 not gonna be stable?
  • Vanilla runs fine on my test server, and I'm using php 5.
This discussion has been closed.