Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Vanilla is proud to present version 2.2.
Please upgrade to 2.1.x here. The 2.0 branch is no longer being updated.

Plain HTML in postings after upgrade ?!

phreakphreak VanillaSkins.com - #1 Themeshop for Vanilla MVP
edited January 2011 in Vanilla 2.0 Help
Hi all,

I just upgraded from 2.0.14 to 2.0.16, but something went wrong.
(I have done upgrades several times before).

Newer discussions show plain HTML-Tags in the postings. {br}, {div} and {p}-Tag.
It seems to affect postings that were made after i installed CLEditor some weeks ago.

Anyone who experienced this before or know a solution.

Thanx
Stefan

VanillaSkins.com - Great Themes and Skins for Vanilla
Ask me to improve your Vanilla forum with OnPage SEO and Competitor Research

Comments

  • phreakphreak VanillaSkins.com - #1 Themeshop for Vanilla MVP
    edited January 2011
    Updated above posting with information about CLEditor.

    VanillaSkins.com - Great Themes and Skins for Vanilla
    Ask me to improve your Vanilla forum with OnPage SEO and Competitor Research

  • phreakphreak VanillaSkins.com - #1 Themeshop for Vanilla MVP
    edited January 2011
    Uh, i guess i did wrong to upgrade directly from 2.0.14 to 2.0.16.

    But i'm not sure because i made a fresh upload of all the data and then dropped my conf and plugin files into the the fresh one.

    One of the pro's has a guess for me??

    Sorry for stressing, made it on a running board. :/

    VanillaSkins.com - Great Themes and Skins for Vanilla
    Ask me to improve your Vanilla forum with OnPage SEO and Competitor Research

  • phreakphreak VanillaSkins.com - #1 Themeshop for Vanilla MVP
    Ok found the solution. HtmLawd seemed to be deactivated after the upgrade.

    It didn't appear in the Dashboard > Plugins so i edited the config File manually.

    Just added:
    $Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';

    VanillaSkins.com - Great Themes and Skins for Vanilla
    Ask me to improve your Vanilla forum with OnPage SEO and Competitor Research

  • TimTim Operations Vanilla Staff
    Thanks Phreak. Not sure why this happened as none of us have experienced this issue.

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • oliverraduneroliverraduner Contributing to Vanilla since 2010 Switzerland ✭✭
    edited January 2011
    @Tim I encountered the exactly same issue after upgrading to 2.0.17.3

    But why the heck... I did not even know this plugin. After I added it manually to my conf.php, HTML was parsed. But there is no entry for such a Plugin in my /plugins/all list?! There's only the HTMLPurifier...

    Please clarify - because this affects some plugins I wrote. Thanks
  • edited January 2011
    HtmLawed is hidden on a brand new install of Vanilla. It seems to be due to a parameter in the plugin's PluginInfo:

    $PluginInfo['HtmLawed'] = array(
    'Description' => 'Adapts HtmLawed to work with Vanilla.',
    'Version' => '1.0',
    'RequiredApplications' => NULL,
    'RequiredTheme' => FALSE,
    'RequiredPlugins' => FALSE,
    'HasLocale' => FALSE,
    'Author' => "Todd Burry",
    'AuthorEmail' => 'todd@vanillaforums.com',
    'AuthorUrl' => 'http://vanillaforums.com/profile/todd',
    'Hidden' => TRUE
    );


    If you remove 'Hidden' => TRUE from the PluginInfo, the plugin appears in the plugin list.

    Why is it hidden?
  • oliverraduneroliverraduner Contributing to Vanilla since 2010 Switzerland ✭✭
    It's hidden because it should be enabled by default. See the config-defaults.php
  • edited January 2011
    But, even when it's enabled, it's still "Hidden". And you should be able to disable and enable it on the fly whenever you want to. Removing 'Hidden' => TRUE solves everything.
Sign In or Register to comment.