Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Vanilla 2.2.1 is now available.
Please upgrade to 2.2 here. The 2.0 and 2.1 branches are no longer being updated.

mod_rewrite issues on new install of Vanilla 2.0.16

My site is at: hosted by UnitedHosting. I don't know the Linux version. It's a brand new untouched (vanilla... groan) install. I have not imported any legacy data. My server meets all the requirements -
I have set permissions on upload, cache, and config folders to 777.

Clicking on the first discussion I get errors:

I have a standard .htaccess:

# Original
# If you modify this file then change the above line to: # Modified

RewriteEngine On
# Certain hosts may require the following line.
# If vanilla is in a subfolder then you need to specify it after the /.
# (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
#RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]

And I'm getting these errors in the log:

mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary.

php-script: line 8: 5170 Segmentation fault /usr/bin/php-cgi, referer:

Premature end of script headers: php-script, referer:

HELP! I love Vanilla - looks much better than phpBB but if I can't get it working it's going to have to be phpBB.


Sign In or Register to comment.