Fork me on GitHub

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Support for Vanilla Forums Cloud product
Current releases are 2.1.3 (9 Sept 2014) and 2.0.18.13 (5 Aug 2014)

Ready for 2.1? Find out if your favorite plugins are compatible. The 2.0 branch will no longer receive updates after Dec 2014.

Notify

12467

Comments

  • I upgraded from 0.2 to 1.2 today and am getting the following error everytime I post something on my site Notice: Undefined variable: mTitle in /home2/vzx/public_html/temple/extensions/Notify/default.php on line 309 Notice: Undefined variable: mComment in /home2/vzx/public_html/temple/extensions/Notify/default.php on line 309 Notice: Undefined variable: mUser in /home2/vzx/public_html/temple/extensions/Notify/default.php on line 309 What am I doing wrong?
  • I just found out that the above error was related to setting NOTIFY_AUTO_ALL to 1. When I set it back to 0, I did not get any error. Strange! Can anyone explain what's happening over here?
  • What's happening: the notify extension is throwing errors.
  • Something was pointed out. If you subscribe to the forums, you get notified about updates in categories that the role you belong to can't view. Clicking the link simply says the thread can't be found. Anyway to have the addon check to see if you have the permissions to view the thread before emailing you?
  • I've tried to get this extension to work and wasn't successful. Are there debugging options to enable to figure out what's going on? FWIW, the Zip2Database plugin DOES work for me, i.e. I receive backups, so I'm pretty sure the email setup is fine.
  • Ok. I FINALLY got this working. Seems that I somehow accidently deleted my /js/ folder. Weird, eh? Anyways, here is my new question:

    Using the global settings extension, how would I set so that everyone is notified for 1 specific category? and are notified of whispers sent to them? (Is that related to this extension?)

    Also, how can we change the permissions so that people can't subscribe to full forums or categories by default (minus the one category that I can do with the global setting)? I don't mind if they subscribe and unsubscribe from their discussions, but I don't need them notified of all forum posts, especially since we haven't fixed the issue that it only notifies them of posts that apply to them.
  • When editing a user's settings as administrator (eg. through Search → Users), the "Notification" section does not show the user's settings, but the administrator's, thus not allowing an administrator to review and configure a specific user's notification settings. Is this behaviour intended? If so, I don't think the "Notification" section should show up at all for the administrator's panel, as it has nothing to do with a specific user other than the administrator himself.
  • I ran into the same issue as Afran. I'd like to be able to edit member's notifications, and the current setup does not allow me to.
  • Hello, thanks for the Notify plugin. It works for me, but I have one thing I'd like to improve; The link provided only links to the discussion; it would be better if it pointed to the first unread comment in one discussions like the links to discussions on the discussion grid.
  • I dont know what Im doing wrong, but I just installed this addon and no emails are coming through to me. I checked the mail settings and they are all fine. Even changed them to different accounts just in case. I have it set to notify me for everything. I made a couple test posts but nothing comes through. What should I be looking for? Thanks
  • I'm having the same issue as vzx. Notice: Undefined variable: mTitle in /home2/vzx/public_html/temple/extensions/Notify/default.php on line 309 Notice: Undefined variable: mComment in /home2/vzx/public_html/temple/extensions/Notify/default.php on line 309 Notice: Undefined variable: mUser in /home2/vzx/public_html/temple/extensions/Notify/default.php on line 309 Any clues? Daniel
  • With forum name in asian characters, the subject of notification mail would be corrupted and not-readable. I've made some modifications to meet the RFC 2047 standard to encode mail subjects correctly.

    1. Notify/default.php:350

    From:

    $e->Subject = $DiscussionForm->Context->Configuration['APPLICATION_TITLE'].' '.$DiscussionForm->Context->GetDefinition('Notification');


    To:

    $e->Subject = mailSubject( $DiscussionForm->Context->Configuration['APPLICATION_TITLE'].' '.$DiscussionForm->Context->GetDefinition('Notification') );


    2. and add the mailSubject() function's code like follows.

    function mailSubject( $str ) {
    $result = '';
    $strArray = explode( ' ', $str );
    for ( $idx=0; $idx<count($strArray); $idx++ ) {
    if ( $idx > 0 ) {
    $blank = ' ';
    } else {
    $blank = '';
    }
    $result = $result . '=?utf-8?b?' . base64_encode( $blank . $strArray[ $idx ] ) . '?=';
    }
    return $result;
    }


    That's it!
  • I believe there is an error in the notify setup - Notify adds a number of fields to lum_user, specifically 'SubscribeOwn' & 'Notified', that are defined as "not null". This is causing a fatal, non-recoverable error when a new user record is created, i.e. a new user tries to register. SInce the fields are defined as 'not null' and default values are not supplied, the result is a fatal error.

    So I'm thinking you can either set defaults to 0 and hope that's correct or redefine the fields to allow nulls and again, hope for the best. Either fix will allow users to register again - but I've no idea if Notify will like these solutions. Hutstein, can you comment?
  • Just installed the plug in NOTIFY. Have read the many other comments and I must say everything seems to be working great for me. EXCEPT...no email. And I see many others have brought up this issue. But many of the answers I see seem to fix other issues, not just the email issue notifying the user that a new post is made. Is there anyway just to fix this one issue...so users can receive email notifications of new posts. Just this one issue, I get NO other error messages, nothing gets froze, all seems fine. Just the email issue. Please help or suggest.
  • I use email in the zip2mail add-on successfully. The code uses the mail() function.
    mail($to,$subject,$mail_body,$from);

    The Notify add-on uses uses the send() function.
    $e->Send();
    I don't know the difference between send() and mail(), but perhaps someone can tell me.
  • The mail function uses sendmail on the server (assuming it's running) the Send function is one of vanillas functions and uses either sendmail or smtp depending on whch is configured in your application settings. Technically Send is the correct way to do it since mail wont work if servers dont have sendmail installed.
  • So, help me brainstorm and try to figure out the difference between how Notify builds the email structure and how I do it in my add-on. Notify builds the $e object and then fills each component: $e->AddFrom, $e->AddRecipient, $e->Subject and $e->Body. Then it uses $e->Send(). It looks like it has something in the $e->Body called $test which is not in the script. Could this cause the problem?
    $e->Body = str_replace(array("{forum_name}","{topic_url}"),array($DiscussionForm->Context->Configuration['APPLICATION_TITLE'],ConcatenatePath($DiscussionForm->Context->Configuration['BASE_URL'].'comments.php?DiscussionID='.$DiscussionID,'')),$EmailBody).$test;
  • That $test value does seem to be slightly errant. I wonder if Mark left that in there by accident... Can we confirm whether the notify extension works either with or without the SMTP settings?
  • I have tried to post messages to see if I get email notifications with AND without SMTP settings, and neither seems to work.
  • I have this setting: smtp.gmail.com:465

    I get notifications all the time.

    Posted: Friday, 13 July 2007 at 7:26AM

  • I have managed to get notify working by doing a fresh install and leaving the SMTP settings blank. I now get messages every time. I would assume then that mail() is working for me when send() was not. I have also set automatic notification on in the settings file. - Daniel
  • We need to make users automatically notified of all forum on signup, but at the same time they can have a link to unsubscribe/subscribe. Any clues?
  • Try the global preferences extension
  • which preference name should I switch to "1" ? Can´t find the name
  • Oh..hmm....the Notify extension doesnt use preferences it uses DB entries so actually that wont work, sorry. I wonder how it's easiest done in this case then... You could run a sql script to change everybody to auto notify but then that'd also wipe peoples preferences if they'd turned it off. Maybe you'd need to attach to a delegate somewhere during user creation and enable it then.. Any ideas guys?
  • While evaluating Notify, I discovered Javascript bugs related to prototype not being included. I tracked this down to what looks like a bug in line 429 of the extentions, where the three "AddScript" lines aren't braced in. I added these braces, and this fixed the js error. However, the extension still doesn't work for me :-(...no emails.
  • Nothing seemed to happen after I clicked any of the checkboxes because there seems to be a problem with the ajax request URL. Changing Notify/functions.js:10 to this seems to do the trick. var ajax = new Ajax.Request(parent.location.protocol + '//' + document.domain + '/forum/extensions/Notify/ajax.php', { There is also an extra statement that needs to be commented out or else the line will disappear after you click the checkbox (because it setting its innerHTML to nothing) just comment it out and it should work. Notify/functions.js:17 //$(Elem).innerHTML = NewText;
  • I understand that Notify sends an e-mail when a comment is made to a discussion the user has subscribed to. Is there any functionality available that goes the other way? Could a user potentially reply to the e-mail, and have that message tack on a new comment to the forum discussion?
  • FYI: I'm working on a complete re-make of the Notify extension! so hold on I will soon launch it...
  • Great stuff hutstein, I love the way it works now.
    It would be great if there was an option to remove it from the panel and put all the controls on the account page?
This discussion has been closed.