Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Inline Images

edited January 2007 in Questions
This discussion is related to the Inline Images addon.
Inline Images
«134

Comments

  • I can't seem to get this to work.
    http://gliving.tv/community
  • it works fine for me. have you installed the other extention that this one requires? It does say that it needs it quite clearly :)
  • You need to enable JQuery and JQThickBox first, before enabling this extension. If the javascript doesn't load in this order, you'll end up with a non-working Thickbox.
  • thats strange, I dont have those two addons Jazzman. Not unless they come with one of my other addons unbeknownst to me..
  • *IF* you want a Thickbox effect on your inline images, you will need to install and enable JQuery and JQThickbox *BEFORE* the InlineImages extension. If you don't want the Thickbox effect, then you do not need either of the JQ extensions ;)

    Hope this is clear.
  • Silly question perhaps, but is there an add-on to determine/
    rearrange the extension load order?

    If not, is it impossible or just considered overkill?

    I can deal with 'this extension requires XXX or YYY' but that
    whole 'load order' stuff isn't something that I'd consider
    'long-term memory material' and bound to frustrate the hell
    out of me in the near future.
  • Oh I found a minor problem. When a user submitted a file with a aprostrophe in the filename ('), the inline image will not show up although the attachment link is still there.
  • That is hardly surprising kifo.. Dont use special characters like that in filenames. Specially not ' or " as they will end Strings..
  • In all fairness, coping with anything that you can put in a file name in Windows, Linux and OSX, is something that Inline Images should be able to cope with. Most users don't even understand what you mean when you say "string" and shouldn't have to. I'll add my vote to getting this sorted in the next update of Inline Images (or Attachments, whichever is at fault) ;)
  • this extension is not working correctly on ie 7. it adds scrollbar . here is a screenshot http://img71.imageshack.us/img71/2904/messedaa0.jpg
  • I still can't get it to work.. http://gliving.tv

    I turned it off, because it just confuses members and I have spent hours trying everything to make this thing work. Seems simple but it just doesn't want to work.
  • How to add a "Full size Link" under the pictures if ur using thickbox for whatever reason

    open up default.php in inline images folder
    At line 56 which looks like this
    $ImageBody = '<a href="'.$WebRoot.'exten..................... Blah blah
    AFTER that line add this
    $ImageBody .= '<p style="margin:0; padding:0 0 15px 0;"><a href="'.$WebRoot.'extensions/InlineImages/image.jpg.php?AttachmentID='.$Attachment->AttachmentID.'">Full size link</a></p>';
  • /hug MySchizoBuddy
  • after some more styling im getting this pretty close to perfect. now I have one more challange. I have a post on my forum where the user has embeded (with html formatter) 4 images as well as attached (and showed with inline/thickbox) 3 images. I think a perfect solution for this might be to have the option to embed images as it now works OR having the images one is hotlinking display on the inline thickbox gallery with the other. hmm.. am i making sense?
  • In a word, no :D Please try again :)
  • consider this: a post with one paragraph of text, 3 images embeded using html code and hotlinking from another site and 3 attached images (using attachment 2, inline images and thickbox). Now you will see 3 full size images (taken that no width or height has been set) and 3 thumbnails that can be clicked to open thickbox gallery of the attached images. wouldnt it be great if the 3 embeded images could be part of the gallery instead of shown in the comment body? my other point was just that this effect should be optional :)
  • Attachment works okay with special characters like ('). It prefaces the ' with a reverse slash. Perhaps this is what breaks inline images?
  • Eh, I still don't get it - I was up late last night, so it's probably me being thick. I came closer to getting it though - could you create a mockup? (or could someone else whisper to me in words of one syllable or less?)

    I get it (I think)!

    You want the option to include externally linked images (not uploaded with Attachments) in the <div id="Attachments_XX" class="Attachments">?
  • im not sure about the specific, but i am looking for the option to treat hotlinked images the same as the attached ones - if that makes more sense. a mock up would look like I had attached 6 images on a forum that has inline images and thickbox extension
  • I think I am missing a very basic step, like exactly how to "tag" an attachment as an inline image. I installed attachments 2.1 and activated it. Then inline and activated it. After adding a comments, there is a browse for attachment dialog that successfully uploads the attachement. Problem is, when the comment is posted, the attachment is just listed. It cannot be accessed and does not appear as an inline image. Any ideas anyone?
  • Turns out the directories for Attachments and InlineImages is hard coded. I had not used the exact names.
  • this extension is not working correctly on ie 7. it adds scrollbar . here is a screenshot
    image

    I see the same thing in Internet Explorer 6.0. Firefox is working well.

    You can fix this by

    removing height: 1%; at line 10 in style.css (inside the extension directory)
  • Now that I have Inline Images working as intended, I would like to make use of the image tag Jazzman referred to above "Users can use an image tag (e.g. [Image_154]). You can only use the image tag for comments where you uploaded the image to."

    When adding comments, we can browse for the image. It is uploaded and appears as an inline image in the post. I have tried every combination of the tag in the comments section and the upload dialog, but apparently not the combination that works. It is easy to see the id given an image by right clicking a post. Doing so would produce http://www.mydomain.com/vanillaforum/extensions/InlineImages/image.php?AttachmentID=26

    So, how could I use this image again in another post without uploading the same file again?
  • What I have done for my forum is hack together the solution you see below. Its a file library of all uploaded files. By making a category that is hidden from view all places but category page, but making it possible to post to it, named ("File hosting"), I have also converted added the functiob of letting my users host file on my server. If there is enough demand, I mayhap could be convinced to make it into an add-on.. http://alek-3d.be/screeny.gif (click on this to view a screenshot)
  • MrDo
    thats nice work
  • Hi!

    Mr Do, I would like to have this as addon!
  • ok. ill start to look into it. maybe it will be done over easter
«134
Sign In or Register to comment.