Fork me on GitHub
Current releases are 2.1.3 (9 Sept 2014) and 2.0.18.13 (5 Aug 2014)

Ready for 2.1? Find out if your plugins are compatible. 2.0 will no longer be updated after Dec 2014.

Vanilla 2.0.13 Released

TimTim Lord of Servers Vanilla Staff
edited October 2010 in Vanilla 2.0 Help
This discussion is related to the Vanilla addon.
Vanilla 2.0.13 has been released!
This is a bugfix release for the SaveToConfig() issue in 2.0.12.

v2.0.13 Changes

  1. Fixed bug with SaveToConfig() where plugins could not be enabled through the interface.

Vanilla 2.0.12 has been released!
This is primarily a feature release for Mobile, but also includes some minor bugfixes for issues in 2.0.11.

v2.0.12 Changes

  1. Added default automatic support for Mobile themes for clients visiting from portable devices

  2. Fixed bug in Authentication where known authenticators could not be made default

  3. Fixed bug with deleted discussions where the page would not redirect after deletion

  4. Fixed bugs with embed vanilla

  5. Cleaned up HTML and CSS

  6. Added hooks for user registrations

  7. Imported some community pull requests

Keeping track of new releases

You can follow our releases by pointing your favorite RSS reader at:
http://www.vanillaforums.org/addon/vanilla-core/follow.rss
This feed will automatically update whenever we release a new version of Vanilla Core.

Troubleshooting the Vanilla 2 Installation

If you run into any issues during the installation, you may see the "Bonk" error screen. In order to get past this screen, you can remove the following line from your conf/config.php file:
$Configuration['Garden']['Errors']['MasterView'] = 'error.master.php';

This will show you a more detailed screen of information about the actual problem you've encountered. Please include this information when reporting issues (copy & paste exact errors, please).

Upgrading Vanilla 2.0 Forums


  1. Sign into your existing forum with the user that was created when you FIRST INSTALLED Vanilla (the root admin user)

  2. Back up your database.

  3. Back up all of your existing files.

  4. Unarchive the new files and copy them over your existing files. Make sure that your hidden files (ie .htaccess) are copied to your server.

  5. Make sure the conf/config.php from your old version has been copied over to the new version.

  6. Delete all *.ini files in your cache/ folder

  7. Navigate to the page in your forum that updates your database (this will not work if you did not sign in as UserID = 1): www.yourforum.com/utility/structure

  8. Scroll to the bottom of the page and click the button to run the update scripts.

  9. Navigate to your forum and test away!

For more help with upgrading, check out the Upgrading Tips and Tricks thread.

Reporting Issues

DO NOT REPORT ISSUES ON THE COMMUNITY FORUM

Please report all issues on the GitHub Issue Tracker. Remember to do a quick search through the issues to make sure your issue has not already been added or resolved.

See the add on page for additional instructions.

Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

Tagged:
«1

Comments

  • edited November 2010
  • Yes! I've been waiting for this :) thanks.
  • candymancandyman ✭✭
    edited November 2010
  • jawsome! Cant wait to upgrade

    hopefully 5. doesn't break any custom themes.
  • TiGRTiGR
    edited October 2010
    Just as a side note, couldn't you automate at least some steps for upgrade process? I mean steps 6, 7, 8 could be performed automatically every time vanilla version gets bumped.

    Simple solution is:

    1. Let vanilla after successful installation put file conf/version.php, holding only version number.
    2. Let bootsrtap check if version number from that file corresponds with version number from index.php.
    3. If versions differ, go steps 6-8 and update conf/version.php.
    4. Make users happy.
  • Re: your rss feed.

    1. It has pretty weird feed title - "Vanilla 2.0.12 by Tim - Vanilla Forums", while it should read something like "Feed for Vanilla Forums updates" or similar.
    2. Every post in it has dumb text, while users are expecting to see some release notes or at least changes (what's new).
  • TimTim Lord of Servers Vanilla Staff
    edited October 2010
    @TiGR I have been insanely busy. I'm aware that the RSS isn't a crazy perfect dedicated feature that makes you dinner and washes your dirty laundry, but at the same time it only took me 10 minutes to do while I was waiting for a long running task to finish:

    <?php
    if (!defined('APPLICATION')) exit();
    $Access = ($this->Data('Slug') ? urlencode($this->Data('Slug')) : $AddonID);
    ?>
    <description><?php echo Gdn_Format::Text($this->Head->Title()); ?></description>
    <language><?php echo Gdn::Config('Garden.Locale', 'en-US'); ?></language>
    <atom:link href="<?php echo Url('/addon/'.$Access.'/follow.rss'); ?>" rel="self" type="application/rss+xml" />
    <?php
    $SlugBase = AddonModel::Slug($this->Data, FALSE);
    foreach ($this->Data('Versions') as $Version) {
    $VersionSlug = urlencode($SlugBase.'-'.$Version['Version']);
    ?>
    <item>
    <title><?php echo Gdn_Format::Text($this->Data('Name').' '.$Version['Version']); ?></title>
    <link><?php echo Url('/addon/'.$VersionSlug, TRUE); ?></link>
    <pubDate><?php echo date(DATE_RSS, Gdn_Format::ToTimeStamp($Version['DateInserted'])); ?></pubDate>
    <dc:creator><?php echo Gdn_Format::Text($this->Data('InsertName')); ?></dc:creator>
    <guid isPermaLink="true"><?php echo Url('/addons/addon/'.$VersionSlug, TRUE); ?></guid>
    <description><![CDATA[<?php echo Gdn_Format::Html($this->Data('Description')); ?>]]></description>
    </item>
    <?php
    }


    Here's how I see it:

    You guys ask for something. I see a quick and easy way that I can solve the spirit of the problem (notify you when an update has happened) without wasting tons of my time. I do it. You complain that it is "dumb" and isn't perfect.

    This makes me not want to do anything for you anymore.

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • AdrianAdrian Marketing Jedi Montreal Vanilla Staff
    edited October 2010
  • LincLinc Community Instigator Detroit Vanilla Staff
    Unf.

    Side note: 2.0.12 lets you disable hashtag linking and YouTube/Vimeo embedding with config values (added to config-default.php).

    Sr Developer at Vanilla Forums, humble servant of Lord Brackos, & pro smatcher. [GitHub, Twitter]

  • @Tim, that's okay, just put it somewhere on your todo list :)
  • edited October 2010
    Thanks so much for the new release! I switched back to 2.0.11 though. Strange things occurred when I upgraded. haha. Only the default theme worked, and I couldn't enable plugins. But, could just be me.
  • blizeHblizeH
    edited October 2010
    Love it, thank you! Can't wait to try it on my iPhone now too.
  • edited October 2010
    I'm not sure if this was on purpose or not but the latest release doesn't contain the "Smarty" directory in the cache folder. This is what was causing the embed theme to not work for me. The Vanilla theme worked just fine, but every time I would switch to the embed theme I would get the "Bonk" screen. I finally actually read your instructions for once :), and realized I can bypass the Bonk screen to see the error. The error I saw basically in a round about way stated that it couldn't find the "Smarty" directory. Then, the light bulb blew up in my head and I said, hmmm, let me check the old version of my forum. Sure enough, that version, which worked, had this Smarty folder. New version does not. After uploading the Smarty directory and it's files into the new version's cache folder, all is well with the universe again. All it took is me not freaking out and thinking. Imagine that.

    Did I mention that I love you guys? Did I just make it awkward in here?
  • edited October 2010
    Loving the update. Only issue I've run into so far is Mobile User agent detection. Looks like the code isn't picking "Android" out of the user agent string for Android phones. If the Android phone doesn't return a Wap profile (opensource/custom firmware), then the IsMobile function is passing it back as a non mobile browser. I fixed this by adding "Android" to the preg_match on line 775.
  • edited October 2010
    How can I remove "index.php?p=/" from the urls? I

    my htaccess is


    # Original
    # If you modify this file then change the above line to: # Modified
    <IfModule mod_rewrite.c>
    RewriteEngine On
    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>


    but doesn't work
  • edited October 2010
    doesn't break any custom themes.

  • TimTim Lord of Servers Vanilla Staff
    I'm not sure if this was on purpose or not but the latest release doesn't contain the "Smarty" directory in the cache folder.
    Not on purpose! Thanks for the heads up, it has been added back in to unstable.

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • @Tim for every 1 person that complains, there are 10 that silently appreciate everything you guys do... the appreciate ones just aren't as vocal as the dumb ones lol

    or as denzel washington said in American Gangster "the loudest one in the room is the weakest one in the room"
  • is there a way to turn off the theme-switching for mobiles?
    my custom theme is already mobile friendly (css solution), and i don't want to use the mobile theme, thanks
  • SS ✭✭
    edited October 2010
    Who has problem with disappearing items/links in dashboard @ sidemenu by custom apps/plugins
    Add
    $Configuration['Garden']['DashboardMenu']['Sort'] = False;
    to conf/config.php
  • Heads up...

    In the upgrade instructions it says to leave the "conf" folder intact, but the mobile theme will not work if you do that.

    In order for the mobile theme to kick in on mobile phones, you have to over write the old "config-defaults.php" file with the new one in the 2.0.13 package.

    It's awesome I'm loving it!
  • TimTim Lord of Servers Vanilla Staff
    is there a way to turn off the theme-switching for mobiles?
    my custom theme is already mobile friendly (css solution), and i don't want to use the mobile theme, thanks
    $Configuration['Garden']['MobileTheme'] = FALSE;

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]

  • LincLinc Community Instigator Detroit Vanilla Staff
    @S I experienced this problem as well; it is now patched in unstable branch.

    Sr Developer at Vanilla Forums, humble servant of Lord Brackos, & pro smatcher. [GitHub, Twitter]

  • Hi! Help? :) I'm trying to upgrade from 2.0.11. Because I'm using ProxyConnect, I also copied over ProxyConnect to the plugins folder before trying to /utility/structure.

    I can log into the admin fine, the utility updates, but… the main page of the forum just says "Bonk!".

    How can I figure out what's wrong?
  • TimTim Lord of Servers Vanilla Staff
    From the original post in this thread:

    Troubleshooting the Vanilla 2 Installation


    If you run into any issues during the installation, you may see the "Bonk" error screen. In order to get past this screen, you can remove the following line from your conf/config.php file:
    $Configuration['Garden']['Errors']['MasterView'] = 'error.master.php';

    This will show you a more detailed screen of information about the actual problem you've encountered. Please include this information when reporting issues (copy & paste exact errors, please).

    Vanilla Forums Senior Developer [GitHub, Twitter, About.me]


  • 3. Fixed bug with deleted discussions where the page would not redirect after deletion
    This problem still exists when deleting private messages.
  • This is great. Exactly what I've been wanting for my forum, for which we're only testing things out at the moment (http://www.bangthebore.org/vanillatest)

    Generally great for smartphones. Smooth and quick, nice layout. Feels as good as posting to the site on my desktop.

    I'll do some more testing tonight, these are my thoughts for now:

    1. Signing in and out. Was hoping that this would be fixed in the upgrade but it's not working, it's giving a 'Page not found' page for every sign-in and sign-out. A two-click workaround for this, just click back then refresh. Still, this will be people's first experience as a forum member and so it might be off-puttingly buggy. I'm wondering whether it's an issue with how we've installed the forum as I can't see that many other people here have had this problem. Thoughts?

    2. I'm no programmer, but a friend drafted a workaround so that the main page just lists the categories. I've just restored that php file after the upgrade... It works fine on the desktop but not on the Blackberry, where the main page is now just blank. But I can click on 'Discussions' to see a list of topics in chronological order for when they were last posted, so it's a one-click workaround. Any ideas how to fix this for good?

    3. Photos & embeds: these work fine on the desk top but are not automatically resized for Blackberry. They distort the shape of the forum on the smartphone browser. I don't like forums with lots of embedded and photographic content but realistically we'll be running a music forum, so people are going to do it. Any ideas?

    4. On certain forums the forum name button has lost its right hand border when you go into an individual topic. A very minor aesthetic thing that I've found with both versions of the forum, both pre and post upgrade.

    Thanks tons for this, though. Vanilla for smartphones was top of my wishlist and it's pretty great so far!
«1
Sign In or Register to comment.