Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Confirmation email required badge always appearing

edited January 2012 in Questions

Hi

When someone tries to subscribe to our forum, he gets a confirmation email, along with a badge stating:

'You need to confirm your email address. Click here to resend the confirmation email'

When he clicks on this link, he receives an email, and when he clicks on the link inside the mail, he sees the following information:

Your email has been successfully confirmed.

However, the badge is always there and doesn't disappear.

What am I doing wrong here?

Using Vanilla 2.0.18.1 (upgraded from 2.0.18).

(Btw: Many thanks for this great software!).

-- Gorkem

Tagged:

Answers

  • badge?

    You mean notice. user should be able to dismiss notices by clicking on the x. It might be that you have a style obscures the x.

    grep is your friend.

  • Yes, I meant "notice" :) Sorry for misleading.

    User can dismiss the notice by clicking on "x", but whenever he logins again, it re-appears.

  • 422422 Developer MVP

    Reappears but what does it say ? If he has confirmed and he is logged in, he may seeother notices but not the please confirm email one

    422 Real Estate Australia , now open Check it out

  • The same notice reappears. He always sees exactly the same notice. Even confirmation of the email doesn't help the notice disappear.

  • 422422 Developer MVP

    One person or more than one person ? Has that user got a cookie issue

    422 Real Estate Australia , now open Check it out

  • At least three that I know of. I also tried, with another new login + password, and wasn't able to remove the notice. I'm sure I don't have a cookie issue with my browsers.

  • 422422 Developer MVP

    We have approx 12 demo forums and never seen this issue. Perhaps Todd , Lincoln or Tim may be able to assist

    422 Real Estate Australia , now open Check it out

  • as long as you dont tag them :p

    422
  • I welcome any assists here - do not know what's wrong with my forum.

  • @x00 I checked again and there's no (x) there - some other notification popups have, but not the "You need to confirm your email address. Click here to resend the confirmation email" notice.

  • ToddTodd Chief Product Officer Vanilla Staff

    First off, this may be user misunderstanding. They have to click on a link in the email that gets sent to them to confirm their email. You should register for an account yourself to see if there is something wrong with your process.

    Second go do /role/defaultroles and make sure you don't have the Confirm Email role as your member role. Also go to your registration settings and make sure you don't have Member as your email confirmation role.

  • Hi Todd,

    1) I went to /role/defaultroles and saw that I don't have Confirm Email role as my member role. Didn't make any changes here.

    2) I went to registration settings and saw that I have member as email confirmation role. I set it blank.

    Now I do not see any notification, but now I'm immediately granted access to the forum as soon as I create a new user, which I do not want.

  • hbfhbf wiki guy? MVP

    gorkemcetin said: Hi Todd,

    1) I went to /role/defaultroles and saw that I don't have Confirm Email role as my member role. Didn't make any changes here.

    2) I went to registration settings and saw that I have member as email confirmation role. I set it blank.

    Now I do not see any notification, but now I'm immediately granted access to the forum as soon as I create a new user, which I do not want.

    set member to the member role.

  • @hbf how do I "set member to the member role" ? Had a look at the settings but don't see what you mean.

  • hbfhbf wiki guy? MVP

    gorkemcetin said: @hbf how do I "set member to the member role" ? Had a look at the settings but don't see what you mean.

    there should be a role called member. use the drop down and select it. you might need to put a screen shot up if you are not seeing this option.

  • Yes, there's a member role (under Roles & Permissions), but there are no drop-downs there - ony draggables and buttons.

    Could you please which URL should I point to, to try your solution?

    • /dashboard/role ? (Roles & permissions link)
    • /dashboard/settings/registration? (Registration link)

    Thanks.

  • hbfhbf wiki guy? MVP

    gorkemcetin said: Yes, there's a member role (under Roles & Permissions), but there are no drop-downs there - ony draggables and buttons.

    Could you please which URL should I point to, to try your solution?

    • /dashboard/role ? (Roles & permissions link)
    • /dashboard/settings/registration? (Registration link)

    Thanks.

    i apologize, under registration the e-mail confirmation role should be set to confirm email. then when someone confirms their e-mail it should change their role to member

  • @hbf Thanks.

    When I was having issues, it read "confirm email" under registration.

    However Todd said:

    "Also go to your registration settings and make sure you don't have Member as your email confirmation role"

    And I changed this to blank. And "Require users to confirm their email addresses (recommended)" is unchecked.

    So if I do what you suggest, I'm sure I'll face this issue again.

  • you should change it to Confirm Email, rather than blank

  • Hi, I've got a new install of vanilla and have the same issue.

    I setup a test account, and confirmed via email link etc. However the pop-up wont go away (and there's no X to close it) Please help!!

    thanks

  • I may have solved this.

    Because I imported from punbb, that process seemed to wipe out some of the roles. I was missing the 'confirm email' role for example.

    Having created that role - the problem seems to have gone away.

    Thanks.

    hgtonight
  • Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • I'm also getting the same problem like this. Is there a simpler way to solve it?

  • LincolnLincoln Community Instigator Vanilla Staff

    @Chiprang said: I'm also getting the same problem like this. Is there a simpler way to solve it?

    Yes, Todd's answer: http://vanillaforums.org/discussion/comment/151566/#Comment_151566

    Sr Developer at Vanilla Forums [GitHub, Twitter]

    UnderDog
  • @Lincoln, Thanks for the URL, but it is not working or maybe i have messed up the Member Role setting. Can you please look at this screenshot

    Thanks

  • @Lincoln, That screenshot setting is OK...now. The email confirm notification notice disappeared after i select the Require users to confirm their email addresses (recommended) in the theRegistration Settings. I also select 'Confirm Email' Users will be assigned to this role until they've confirmed their email addresses. Quite Strange! Don't you think 'Member' should be selected.

    Also, new user is able to post even before Confirming email.

  • I think i got it now...bt the only issue that remains is... Even applicants who are yet to verify their emails can immediately make a post. How to prevent that?

  • look in the confirm email role and fix the permissions or post a similar image as you did above for members, except for confirm email role.

    remove the add permissions in that role under the categories toward the bottom. remove the edit profile and anything else you don't want confirm email to do in the role permissions.

    Ensure that anyone who is a member doesnt' also have confirm email role.

    you should easily be able to roles for all users twith membership enhanced plugin

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

    UnderDog
Sign In or Register to comment.