Fork me on GitHub
Current releases are 2.1 (gold) and 2.0.18.11 (security patch for 2.0)
Ready for 2.1? Find out if your favorite plugins are compatible.
The 2.0 branch will no longer receive updates after Dec 2014.

[Solved] Import bonk on vanilla 2.0.18.3

edited August 2012 in Vanilla 2.0 Help

Hai,

First of all thanking vanilla forum makers for this wonderful open source forum.

Recently i had downloaded you new version(ie 2.0.18.3) of vanilla forum and installed it on server(not in local machine). On the first login i clicked the import icon and it end-up with the bonk message.I want to know why this happened ? can anyone please help me.

Thanks in advance

Best Answer

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    Answer ✓

    In your Vanilla/conf folder find config.php and add this line:

    $Configuration['Garden']['Debug'] = TRUE;

    This will give you a detailed error, rather than the bonk page.

    Either post the error result here, or post a new question if you can't see how to fix it.

    sonus
«1

Answers

  • Thanks for the replay whu606

    I had added the line on conf/config.php. But at the time of execution apache reedit the file and remove the line on config.php.And end up with the bonk page again

  • Hi, I have exactly the same problem. I'm migrating from Vanilla 1.x. I write the right email/password, but I always got "bonk". I'm working on localhost. And regarding to the line for the debug, this line is already wrote inside config.php, but nothing is showed when the bonk happens.

    Thank you for your help.

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP
    edited June 2012

    but did you add this line also?

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';
    

    and did you read this:
    What to do if I get a Bonk Error? in underdog's signature.

    or did you read this:

    http://vanillaforums.org/docs/errors

    or did you search the last 5 or six messages that explained bonk errors? :)

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

    UnderDog
  • I gonna try with that line... The link to the forums doesn't work (I checked it before to write the post).

  • Ok, I got the error:

    `Fatal Error in Gdn_Upload.SaveAs(); Failed to move uploaded file to target destination (D:\xampp\htdocs\vf2012/uploads/D:/xampp/htdocs/vf2012/uploads/import/VSCXOGUEOGNF.txt). The error occurred on or near: D:\xampp\htdocs\vf2012\library\core\class.upload.php

    212: if (!file_exists(dirname($Target)))

    213: mkdir(dirname($Target));

    214:

    215: if (!move_uploaded_file($Source, $Target))

    216: throw new Exception(sprintf(T('Failed to move uploaded file to target destination (%s).'), $Target));

    217: }

    218: return $Parsed;

    219: }

    220:

    Backtrace:

    [D:\xampp\htdocs\vf2012\applications\dashboard\controllers\class.importcontroller.php:167] Gdn_Upload->SaveAs();

    [D:\xampp\htdocs\vf2012\applications\dashboard\controllers\class.importcontroller.php:167] ImportController->Index();

    [D:\xampp\htdocs\vf2012\library\core\class.dispatcher.php:322] PHP::call_user_func_array();

    [D:\xampp\htdocs\vf2012\index.php:53] Gdn_Dispatcher->Dispatch();

    `

    How could I fix it?

    thank you!

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP
    edited June 2012

    perhaps

    D:\xampp\htdocs\vf2012/uploads/

    D:/xampp/htdocs/vf2012/uploads/import/

    does directory exist? line 213 shows that it tried.

    if not create one and give it appropriate write permissions.

    also curious is the forward slash - backslash deal - I guess thats a windows - unix thing

    actually I'm not sure

    does this exist VSCXOGUEOGNF.txt

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • UnderDogUnderDog Moderator

    I think you can work around this issue. You should place the file you want to import in that uploads directory. D:/xampp/htdocs/vf2012/uploads/import/

    See if you use 2.0.18.4 if that will solve the problem.

    As peregrine says : it's a Windows / Unix issue and should either be solved easily or can be worked around for now...

  • Hello,

    the folder "import" is already created (by vanilla itself). I checked its security permissions, and I found that it hasn't permissions for "creator owner" and for my own windows users. I was able to give it permissions for my windows user, but not for "creator owner". I also put the file to import inside the folder "import", but I'm still getting this error:

    `Fatal Error in Gdn_Upload.SaveAs(); Failed to move uploaded file to target destination (D:\xampp\htdocs\vf2012/uploads/D:/xampp/htdocs/vf2012/uploads/import/JM2YOC02U2N1.txt). The error occurred on or near: D:\xampp\htdocs\vf2012\library\core\class.upload.php

    212: if (!file_exists(dirname($Target)))

    213: mkdir(dirname($Target));

    214:

    215: if (!move_uploaded_file($Source, $Target))

    216: throw new Exception(sprintf(T('Failed to move uploaded file to target destination (%s).'), $Target));

    217: }

    218: return $Parsed;

    219: }

    220:

    Backtrace:

    [D:\xampp\htdocs\vf2012\applications\dashboard\controllers\class.importcontroller.php:167] Gdn_Upload->SaveAs();

    [D:\xampp\htdocs\vf2012\applications\dashboard\controllers\class.importcontroller.php:167] ImportController->Index();

    [D:\xampp\htdocs\vf2012\library\core\class.dispatcher.php:322] PHP::call_user_func_array();

    [D:\xampp\htdocs\vf2012\index.php:53] Gdn_Dispatcher->Dispatch();

    `

    Thank you.

  • hbfhbf wiki guy? MVP

    argie01 said: Hello,

    the folder "import" is already created (by vanilla itself). I checked its security permissions, and I found that it hasn't permissions for "creator owner" and for my own windows users. I was able to give it permissions for my windows user, but not for "creator owner". I also put the file to import inside the folder "import", but I'm still getting this error:

    `Fatal Error in Gdn_Upload.SaveAs(); Failed to move uploaded file to target destination (D:\xampp\htdocs\vf2012/uploads/D:/xampp/htdocs/vf2012/uploads/import/JM2YOC02U2N1.txt). The error occurred on or near: D:\xampp\htdocs\vf2012\library\core\class.upload.php

    212: if (!file_exists(dirname($Target)))

    213: mkdir(dirname($Target));

    214:

    215: if (!move_uploaded_file($Source, $Target))

    216: throw new Exception(sprintf(T('Failed to move uploaded file to target destination (%s).'), $Target));

    217: }

    218: return $Parsed;

    219: }

    220:

    Backtrace:

    [D:\xampp\htdocs\vf2012\applications\dashboard\controllers\class.importcontroller.php:167] Gdn_Upload->SaveAs();

    [D:\xampp\htdocs\vf2012\applications\dashboard\controllers\class.importcontroller.php:167] ImportController->Index();

    [D:\xampp\htdocs\vf2012\library\core\class.dispatcher.php:322] PHP::call_user_func_array();

    [D:\xampp\htdocs\vf2012\index.php:53] Gdn_Dispatcher->Dispatch();

    `

    Thank you.

    temporarily give full permissions to Everyone and try again.

  • I did it and I got the same error.

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP

    since you have created the directory manually and manually moved the file

    try commenting out line 216 in D:\xampp\htdocs\vf2012\library\core\class.upload.php

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP

    argie01 said: http://pastebin.com/SHK2seaQ

    and the point of of posting this was what?

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • Peregrine: that is the error returned.

  • Hi,

    I did this migration on the linux server where I have my current forum, and it worked like a charm. So, definitely this is a problem with back/forward slash, as you say.

    Now I have a question: is there some information that is not migrated? i.e., can I asume that the user's role and password where migrated correctly when I used the import option on dashboard?

    Thank you.

  • Well, I discovered an error on the migration: all the links on discussions has disappeared. I.e. the text of the link remains, but not like a link. Is there a way to fix this problem?

  • UnderDogUnderDog Moderator

    Lol, In my mind I see a little dog running around its axel trying to catch its tail...
    @argie01 you are on your Windows computer. There is a problem with moving a file from one location to another location. That's what the error message says. The problem has something to do with this slash : / and this backslash : \ . Now read my advice from a couple of posts above. For your convenience I will quote my entire advice :

    UnderDog said: I think you can work around this issue. You should place the file you want to import in that uploads directory. D:/xampp/htdocs/vf2012/uploads/import/

    See if you use 2.0.18.4 if that will solve the problem.

    As peregrine says : it's a Windows / Unix issue and should either be solved easily or can be worked around for now...

    Trying to do the same thing over and over again will not work. Try other things, like installing Vanilla 2.0.18.4 and trying to import. Placing the text file in /uploads/import or in /uploads, everywhere, just until you get to the next error message.

    You created your import file on your Windows computer too, as I will assume, so if you're done with this error message, waggle your tail (little doggy comparison) and I'll tell you what to do with the next error message.

  • argie01argie01 New
    edited June 2012

    UnderDog, as I wrote on my last post, I did the migration on my current linux hosting, and the migration was fine, except by a detail: the links on discussions has changed to plain text. But the curious thing is when I check the code on those articles with links, the html code still has the links: but they are showed to users as plain text...

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP
    edited June 2012

    you need to check the format field in the discussions table and comment table needs to be html

    your comments are becoming more and more unintelligible. How did you get the conversion on the windows computer resolved. how did you resolve this? It is customary to say how you resolved it and did any solution work for you?

    which version of vanilla are you using? which OS are we talking about now?

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

    UnderDog
  • argie01argie01 New
    edited June 2012

    Hi peregrine, the problem with the migration happened when I was working on localhost, with Windows XP SP3. As I wrote above (I don't think my posts are unintelligible :), I did the migration (again) on my current hosting (a linux server) and so the migration was OK. And that's all :)

    Regarding to the version of Vanilla I'm using, on my first post I wrote it :) This is the last version of Vanilla.

    But I really don't understand what you're meaning with this comment

    you need to check the format field in the discussions table and comment table needs to be html>

    I.e., I think the migration should migrate fine all post of my old V 1.6.3 forum, without changes. The links on my old forum are standard, as you can imagine. And after the migration those links are showed as plain text (even when I pass the pointer of the mouse over the link, it doesn't change to a hand). But if I edit those post, the code of the links are perfect.

    Regards.

  • UnderDogUnderDog Moderator

    Oh man, it's getting worse... I need a vacation.

    argie01 said: UnderDog, as I wrote on my last post, I did the migration on my current linux hosting, and the migration was fine, except by a detail: the links on discussions has changed to plain text. But the curious thing is when I check the code on those articles with links, the html code still has the links: but they are showed to users as plain text...

    Step by step this is what you should do. Please do not say that you already done that...

    • Open phpMyAdmin
    • Go to the table for Discussions and Comments (2 separate tables)
    • Go to the field that says 'Format'
    • Look at the value of the field 'Format' for some of the entries (records) of your forum
    • Waggle your tail and report back in this thread.

    Please do not ask where phpMyAdmin is or where the tables for Discussions and Comments are, because in that case I will be on vacation for sure.

    argie01 said: Hi peregrine, the problem with the migration happened when I was working on localhost, with Windows XP SP3. As I wrote above (I don't think my posts are unintelligible :), I did the migration (again) on my current hosting (a linux server) and so the migration was OK. And that's all :)

    So the migration is ok? So everything worked out? All items are imported from your old forum to your new forum? Awesome. Good job.

    Regarding to the version of Vanilla I'm using, on my first post I wrote it :) This is the last version of Vanilla.

    According to your first post that you wrote, the version you are using is 2.0.18.3

    Maybe there is a new version of Vanilla in the meantime:
    http://vanillaforums.org/discussion/19542/vanilla-2-0-18-4-released

    But I really don't understand what you're meaning with this comment

    you need to check the format field in the discussions table and comment table needs to be html>

    I.e., I think the migration should migrate fine all post of my old V 1.6.3 forum, without changes. The links on my old forum are standard, as you can imagine. And after the migration those links are showed as plain text (even when I pass the pointer of the mouse over the link, it doesn't change to a hand). But if I edit those post, the code of the links are perfect.

    Step by step this is what you should do. Please do not say that you already done that...

    • Open phpMyAdmin
    • Go to the table for Discussions and Comments (2 separate tables)
    • Go to the field that says 'Format'
    • Look at the value of the field 'Format' for some of the entries (records) of your forum
    • Waggle your tail and report back in this thread.

    Please do not ask where phpMyAdmin is or where the tables for Discussions and Comments are, because in that case I will be on vacation for sure.

    So, if you succeed, waggle your tail and report the contents of that format field

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP

    I'm finished too, until you say how you resolved the windows problem. or if you didn't, did you give up on windows version.

    also latest version doen't fly. your idea of latest version may differ, since you posted under a thread that says 2.0.18.3 whichh is not the latest. so yes it is unintelligible to me. Hasta Luego for now.

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

    UnderDog
  • XDDD you're really funny, guys :) Ok, I gonna check that on phpmyadmin, and I'll post the results here.

    Regarding to the problem with Windows: I didn't resolved it. I simply changed my mind and I thought on test the migration on my current linux hosting, and it worked. So, I don't have any solution to the Windows problem to publish here.

    Regarding to the latest version: sorry, my mistake: all these test were done using Vanilla 2.0.18.4 (and not 2.0.18.3).

  • The "format" for the discussions with the links is "Tinymce". And that is the same for every discussion with links on the forum. The discussions without links are using the "format" "BBCode".

  • UnderDogUnderDog Moderator
    edited June 2012

    Ok, we're getting close. Just do the same steps for phpMyAdmin and make a screenshot of the same tables as I did. 1 line in your phpMyAdmin is enough. Just cut out the information we're not supposed to see, like the address bar.

    I would love to see either 1 line in your comment and discussion tables or a couple of lines in your comment and discussion tables (just like I've shown in my screenshot). Let's continue after that.

    If you can show the contents of the 'Body' fields at the same time (maybe same screenshot) with some links in it (they are giving problems, right?) that would be appreciated.

    By the way: in my screenshot there's a possible solution to showing the links the way they should, so solving your problem somewhat.
    If you conclude that part of the solution yourself, I will make my vacation a little shorter ;-) Just let us know if you've found that solution (in my screenshot).

  • argie01argie01 New
    edited June 2012

    Hi again,

    here I'm posting the images you requested me:

    Bad Comment Table

    Normal code table

    Bad discussion link table

    Normal Discussion Table

    Discussion link code

    Regarding to the solution you told me, I'm not a programmer, but I think the solution should be change "BBCode" and "Tinymce" values for "html", right?

  • peregrineperegrine ☯ hasta luego :) In-Flight MVP
    edited June 2012

    you could use phpmyadmin to set all the formats to html.

    read up on it or search for format sql . Notice how the same questions asked are repeated on this forum and the same workable solutions are also provided. and it requires you to search on the forum creatively. search with google (vanillaforums.org format sql formatter).

    or see this http://vanillaforums.org/discussion/12372/html-not-displaying-after-vanilla-upgradeimport

    also add the following in config.php for future comments and discussions. but I think you already have it correct, because you said it works when you edit comments.

    $Configuration['Garden']['InputFormatter'] = 'html';
    

    I'm really hoping you add the steps on how to fix formatting and html to the wiki - (for the next person).

    Monetary Donations will be appreciated if you use my plugins. Thanks in Advance.
    As a waiter gets a tip for a good meal, tips for successful solutions appreciated as well. Peregrine

  • Thank you peregrine. The solution you pointed me had worked fine. And I didn't find that configuration line inside config.php, so I added it.

«1
Sign In or Register to comment.