Fork me on GitHub
Please upgrade to 2.1.x here. The 2.0 branch is no longer being updated.
Critical: Update to 2.1.8, released 15 Jan.

Fatal error!

edited July 2010 in Vanilla 2.0 Help
This discussion is related to the Google AdSense > After Discussion addon.
when i press on any of the discussios, the following message appears!

Fatal error: Class 'Module' not found in /customers/strukts.com/strukts.com/httpd.www/plugins/GoogleAdSenseSidePanel/class.adsensesidepanelmodule.php on line 6

Could anyone help on this please?

Comments

  • Change line 6 to say "extends Gdn_Module" where it previously said "extends Gdn_Module". I have sent a message to the plugin creator asking him to fix this as I'm sure it will be a popular plugin.
  • "extends Gdn_Module" where it previously said "extends Gdn_Module". Both are same!
  • bobthemanbobtheman
    edited August 2010
    would either of you by chance have any info on piwik and v2? http://www.piwik.org

    "Piwik aims to be an open source alternative to Google Analytics."
  • Thanks bobtheman forthe link, however my concern is enabling the google adsense in my forum
  • I'm getting the same error, too. Please advise on how to fix!
  • Can we get this fixed please?????
  • AdrianAdrian Promoter of Things Montreal Vanilla Staff
    edited September 2010
    Don't know if you are still looking for a solution for Piwik in Vanilla 2, but here it is:
    Open /themes/YOURTHEME/views/default.master.tpl
    Add {literal} just before end of /body and then paste your piwik code
    then add {/literal}
  • Here is the fix... pretty simple:

    1. Open up the GoogleAdSenseAfterDiscussion folder on your computer
    2. Open the file class.adsenseafterdiscussionmodule.php
    3. look for the line that reads: class AdSenseAfterDiscussionModule extends Module
    4. Change it to this and upload: class AdSenseAfterDiscussionModule extends Gdn_Module
    5. Make $$

    Works perfect for me :)
    vaniller
  • SOLUTIONS: Change line 6 to say "extends Gdn_Module" where it previously said "extends Module"

  • DenisSDenisS My brain hurts Buriram ✭✭

    @mattrl said:
    Here is the fix... pretty simple:

    1. Open up the GoogleAdSenseAfterDiscussion folder on your computer
    2. Open the file class.adsenseafterdiscussionmodule.php
    3. look for the line that reads: class AdSenseAfterDiscussionModule extends Module
    4. Change it to this and upload: class AdSenseAfterDiscussionModule extends Gdn_Module
    5. Make $$

    Works perfect for me :)

    I done this stopped the error on line 5, but ad's still don't show. here's my whats wrong????
    <?php if (!defined('APPLICATION')) exit();
    /**
    * Renders Google AdSense code after the entire discussion on the discussion page in Vanilla.
    */
    class AdSenseAfterDiscussionModule extends Gdn_Module
    {
    // Replace this values which your own AdSense unit code parameters
    protected $_google_ad_client = 'pub-9980064291871969';
    protected $_google_ad_slot = '0390810185';
    protected $_google_ad_width = 728;
    protected $_google_ad_height = 90;

    // Should have a value or be an empty string. An extra class called AdSense has also been added to the Box div.
    protected $_StyleOverride = 'margin:25px 0 0 0; padding:0px; background: none;';
    
Sign In or Register to comment.