Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Wordpress Integration - Sign out Problems

edited January 2011 in Questions
I've been fussing with this - the sign out process when Vanilla is integrated into WP fails most times.

After clicking the the signout link it with either refresh the page with a "blank user" logged in. Even after I delete that user, it still comes back as a result of the signout process. If it doesn't refresh with the Vanilla page, it goes to a WP logout confirmation page. The next time I visit, it still shows as having the blank user logged in.

I tried this fix http://vanillaforums.org/discussion/comment/130686/#Comment_130686, but haven't had any success yet. I was using a caching plugin (W3 total cache) but disabled it thinking it was causing the problem. Even with caching turned off, the problem exists.

Can someone try it out and see what they can find.
username: testybob
password: test123
email (invalid): testing@leafboxtea.com
embedded forum: http://leafboxtea.com/discuss
alternate url: http://leafboxtea.com/social/vanilla
alternate login url: http://leafboxtea.com/social/vanilla/entry/password

I know it has something to do with the cookie getting deleted on logout, but I don't know enough about these things to wrinkle it out.

Comments

  • Did some more testing by switching password authentication (as opposed to ProxyConnect). Problem still exists. I noticed that it is even affecting the users since the forum just got a post from the Blank User account that keeps getting created.

    Since I switched to password auth, I wonder if this is a problem in the core?
  • Implemented this fix: http://vanillaforums.org/discussion/comment/128056/#Comment_128056

    Seems to be working so far, but I'm still testing it through.
  • Right, not fixed.

    Herein lies the problem: Tabbed browsing. Typically when I'm browsing my WP press I keep a tab of the backend dashboard open next to the one I'm working in. If a user is WP logged into a separate tab (frontend or backend, doesn't matter), then when that user logs out of Vanilla the forum reloads with the ghost account. Clicking sign out a second time while in the ghost account takes you to the WP logout confirmation (this happens regardless of ProxyConnect. I was getting this behavior using standard password authentication).

    As long as I was only browsing with a single tab open, the sign out function in Vanilla worked smoothly. As soon as I complicated things by having a second browser tab open, Vanilla got all kinds of confused.

    The error appears when ProxyConnect is enabled and when password is enabled - which then, of course, points to the problem being in the WordPress integratation. Though I have read on these forums that the ghost user problem was happening on embeds on other sites as well.

  • Of course, I don't know how to fix any of this, just trying to help narrow down where the problem lies...
  • MarkMark Vanilla Staff
    @Tim wrote ProxyConnect and should be able to lend a hand.
  • edited January 2011
    Not sure that it is ProxyConnect, I'm using Password Authenticattion right now, but the ProxyConnect plugin is still enabled. Going to disable and see what happens.

    UPDATE: after disabling the ProxyConnect plugin I was unable to recreate the issue and signin/out worked fine. I renabled Proxy and then tried manual integration and then WP integration. I did all the setting changes in my Chrome browser. I then switched to FireFox and deleted all cookies and cleared the cache. On the refresh, the bug came up immediately. I tried to login to my admin account and Vanilla put me into the ghost account instead.

    For the time being, so my users can access, I'm going to switch it all off. When @Tim has responded, I'll turn it back on and work with him.
  • I have embedded Vanilla into one of my website but i have two problems with it. First one is the sign out problem faced by other people as well, when a user signed out of the vanilla forum, he is not completely signed out. Unless he signed out the second time, then he is completely signed out. Why is this problem? Bug maybe? and the second thing, when vanilla is embedded, clicking on dashboard once, continuously refreshes the content without stopping. How to fix this issue. Am using the latest vanilla 2.0.17. Thanks.
  • Another problem with sign out, is that when a user signed in through Facebook and he later signed out of the forum, he is not signed out of facebook yet. How can we make it so that when the user signed out of the forum, he is signed out of facebook as well?
  • edited April 2011
    For all those who have sign out problems try this

    1 go to Dashboard -> Settings -> Routes
    2 Click edit on Default404
    3 Target = your home page (ex: Categories/all) & Type = Internal

    worked for me
  • @jady I have the same problems using vanilla 2.10.18b2. If i sign out i can sign in again by just refreshing the page. Do you or anybody else have a solution?
Sign In or Register to comment.