Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Removing or adding a feature in Mobile Theme

avantime4mikeavantime4mike ✭✭
edited February 2011 in Questions
Can someone tell me how to edit the Mobile theme to remove the "latest" poster information as it is apparently causing display issues on the iPhone.
Also is it possible to add the default theme search box to the mobile theme?

Comments

  • Can someone tell me how to edit the Mobile theme to remove the "latest" poster information as it is apparently causing display issues on the iPhone.
    Also is it possible to add the default theme search box to the mobile theme?
    What kind of issue?
    There was a bug displaying the first poster only in 2.0.16. I saw it corrected in some github commit, but I don't know if it was before or after 2.0.17 being released.


  • @luc Apparently if the text is too long and it spills on to a second line, it causes the display to be unreadable. I assume it's overlaying the line below. I personally think it's a Safari browser issue on the iPhone although my sons iPod touch displays things fine.
  • lucluc ✭✭
    edited February 2011
    @avantimemike
    You can try this new mobile theme (http://vanillaforums.org/addon/green_mobile-theme), it was made by a close friend, and we saw issues similar to what you just described (even though not in the discussion list, but in the notification area).
    I've just added a very long subject line, it does grow correctly on my iPhone 3GS with no overlap.

    If it does work fine for you too, I'll create a pull request on github, as my friend is not current on DVCS :).
  • @luc thanks I'll give that a go tomorrow and let you know how it goes. Will it automatically enable for mobile browsers or do I have to change something else to do that?
  • You have to do what's described in the description ie.:

    To activate this mobile theme after unzipping it in your themes folder (because AFAIK there is no UI for this yet):
    Add $Configuration['Garden']['MobileTheme'] = 'green_mobile'; in your config.php (below the normal Theme for instance); or modify your current value if MobileTheme already exists.
  • avantime4mikeavantime4mike ✭✭
    edited February 2011
    @luc Installed the Green Mobile theme and users have reported the problem solved. Many thanks, Mike
  • @luc How difficult would it be to add the search box to your theme?
  • Thanks for letting me know. I'll have to check, as on my local install, default mobile theme wasn't OK, but on here, it seems OK (and the css file seems to be the same).

    As for the search box, no idea, but the most important thing is to find where to put it, either a small image as the new discussion, or maybe on a line by itself before all the discussion.
    After that, just adding it should be very straightforward.
  • @luc How difficult would it be to add the search box to your theme?
    I'm working on it.
  • Please, Keep us posted.
  • lucluc ✭✭
    edited March 2011
    I guess she will post something this WE, not all the kinks are ironed out, but it's very usable and we will not have the time during next week to work on it.
    We decided to go with an image next to the "new discussion" image, and it will open the search page. To have it before the discussion all the time was taking too many pixels, and each single one of them are useful on a mobile device.

    It won't be forgotten, as we're using that same very theme on our private forum :)
  • lenalena New
    edited March 2011
    It's online. ^^
  • Thanks @lena and @luc I'll give it a try and let you know.
  • @lena OK, uploaded the new 1.1 version but although I now have a little magnifying glass top right, clicking on it clears the screen of the discussion list and leaves just the message in the header. I don't get any search box coming up. Tested using iPod Touch 4G. I've left the theme active so you can have a look at http://www.avantime-owners.com/vanilla unauthenticated users can view some discussions so you should be able to see the problem.
  • avantime4mikeavantime4mike ✭✭
    edited March 2011
    @lena Update, the reason for the search box not appearing is that I have a permanent message displayed at the top of all pages. If I disable the message, the search box appears. Can I disable the display of messages in the mobile theme? I don't want to lose this feature in the main theme display. Thanks again. Mike.
  • lucluc ✭✭
    The magnifying glass icon is not there If not authenticated.
    That's what we are running on our forum that was zipped.
    Tested with an iPhone 3GS with iOS 4.1, and an android 2.2 phone.
    When you clic the magnifying glass icon, it should goes to "/search" and right below, you should have a textbox to enter your search, with another icon to launch the search.

    I tried (using edit of the url) on your forum and it showned OK like a few minutes ago, tried again just now and I've got a "message" for some avantime stuff near where we live :) and it doesn't display it indeed. I guessthe message is making a mess :), we'll have a look.
  • lucluc ✭✭
    @lena Update, the reason for the search box not appearing is that I have a permanent message displayed at the top of all pages. If I disable the message, the search box appears. Can I disable the display of messages in the mobile theme? I don't want to lose this feature in the main theme display. Thanks again. Mike.
    There we found the same thing. :)
    We'll might have time to have a quick look about this tomorrow, as it's easy to reproduce, it might be easy to fix.
  • @luc messages crossed, same conclusion :-)
  • lucluc ✭✭
    Maybe you can leave just the displays of this message in the discussion only.
    The search URL is part of the dashboard, but I don't think that there is an option for all pages except for the message, so maybe discussion only should be enough for you.
  • @luc In the short term that's exactly what I've done. I'm going to try and get my head around the Embed theme so I can place news announcements in the header in future. If you look at my main pages (off forum) you'll see I'm no web wizard so it may take some time :-) Thanks for all your help. Mike.
  • lenalena New
    edited March 2011
    @avantime4mike: it's fixed and uploaded (quick fix because messages will change soon, they are in unstable so will surely be in next release). Thank for your feedback.^^
  • @lena @luc A brief update, installed latest version of your theme and it has been in use for two weeks now with no problems and several positive feedback comments from my users. Many thanks for all your help. Mike.
  • mattmatt ✭✭
    edited May 2012

    @avantime4mike I've created a plugin to add search to the mobile theme: http://vanillaforums.org/addon/mobilesearch-plugin

Sign In or Register to comment.