Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us

Vanilla 2 Upgrading Tips



  • LincolnLincoln Community Instigator Vanilla Staff
    Do you have RewriteUrls enabled for 'pretty' URLs? That's the usual reason for that not working. Copy the 'RewriteUrls' setting from config-defaults.php into your config.php file and set it to true. Then try again.

    Sr Developer at Vanilla Forums [GitHub, Twitter]

  • @dejitaru There is a new permission for that. Adjust your Roles & Permissions.
    I'm getting the same error too :/ Can't figure out which permission I should set. @Lincoln: do you know specifically what has to be set for that? As as admin, I can look at all the profiles, but none of my users can look at anyone else's or their own.
  • edited January 2011
    There isnt anything else to check in for admins.Im logged in as an administrator. I can log in with the #1 account and everything works fine but when I log in with any other account that has administrator rights I still get the permission errors. All boxes are checked in roles and permissions for the admin group. Is there something im not seeing? Also comments arent allowed when posting via mobile site for everyone except #1 account. I started discussion as to not clutter up this thread so you can delete these posts.
  • Do you have RewriteUrls enabled for 'pretty' URLs? That's the usual reason for that not working. Copy the 'RewriteUrls' setting from config-defaults.php into your config.php file and set it to true. Then try again.
    Okay. I didn't know about that configuration. /utility/upgrade still brought up a Page Not Found, but I went to /utility/structure and clicked the "Run structure & Data Scripts" and those were applied, I guess.

    Considering that the RewriteUrls isn't a given, should the upgrade instructions provided here explain that? I have a feeling that this config setting would have saved me and all of you a lot of trouble.
  • TimTim Lord of Servers Vanilla Staff
    @dejitaru @vanik3 There is a bug in the currently published version available for download. It prevents those permissions from being created. I'll more than likely be publishing a new minor version later today containing that fix and several others.

    Sorry for the trouble!

    Vanilla Forums Senior Developer [GitHub, Twitter,]

  • edited January 2011
    I've upgraded from to (preserved the necessary files/folders and copied over new package). Trying /utility/update gives me a 404. There is currently only one user and I'm logged in (though I have changed it from admin to another name; would that not count as user #1? Or, how can I check the user number ID?). Is /utility/update and add-on I need to "install"? Any advice?

    OK, "/?p=/utility/structure" did the trick!
  • update utility works well.
    I would like to know after owerwriting all files with new updated files,how will I keep formatting of my .css files?
  • Upon upgrading to & following tips as per here and this thread I get the following

    /utility/structure to works

    utility/update says BONK

    utility/upgrade gives me a 404

    is this to be expected?
  • Is it bad if I run /utility/update more than once?
  • lucluc ✭✭
    Don't think so. I did it quite a few times when upgrading from beta to 2.0.16 with no adverse effect.
  • TimTim Lord of Servers Vanilla Staff
    Is it bad if I run /utility/update more than once?
    Its fine.

    Vanilla Forums Senior Developer [GitHub, Twitter,]

  • I'm trying to upgrade from 2.0.16 to I followed all instructions at the top of this thread. I'm getting 404's for /utility/update and /utility/structure . My forum is at and so I have been trying (as well as just in case). When I try to go to my forum home page I get a Bonk. Deleting my whole forum directory, and replacing it with my backup have restored my forum to 2.0.16 just fine.

    What am I doing wrong, how do I troubleshoot? Thanks in advance!
  • Same, tried both utility/structure and utility/update
  • TimTim Lord of Servers Vanilla Staff
    PM me your real forum URL

    Vanilla Forums Senior Developer [GitHub, Twitter,]

  • where is the changelog page for 2.0.18 &
  • After spending 45 minutes upgrading from 2.0.16 to 2.0.17, I think that should have been much easier. Some feature requests please:

    1. Separate core vanilla code from things I might install. So let's have core/plugins, core/themes, etc which is separate to plugins, themes, etc that a user might install. In theory the upgrade could be limited to "replace the folder called 'core'"

    2. Even better, .gitignore and all those 'empty' files suggest you use git. :-) So why not let us use 'git checkout v2.0.17' to upgrade if you publish git tags along with each release. How easy is that! Then our local changes are not lost.
  • lucluc ✭✭
    @ari: The code is on github, you can already do that (2).
    For 1, you can just drop the zip, and unzip, unless you modified files from the release, nothing bad will happen.
  • After doing the upgrade from 2.0.17 to 2.0.18 I run the upgrade utility while logged in as user #1 and then I get a blank page. When I clear the address and revisit the site I get a blank page. I replaced the conf files and removed the .ini files like instructed. What went wrong?
  • Can someone help me out with the above issue? I need to upgrade for an addon that I require on one of my sites. Please help me! Thanks.
  • Hi all,
    having problems with this. I'm trying to upgrade this forum to to from
    I've followed the instructions so far as I can see
    -Upload the new package zip file to my server,
    -unzip it,
    -log in as the forum admin,
    -clear out my forum install folder as instructed (save conf etc),
    -copy the files from the unzipped folder over the top of my old install
    -delete the .ini files in cache
    -type into my browser

    I don't get "success", instead I get the vanilla new setup screen. And if I enter the correct values into the fields there I get an "insert duplicate key" error...

    I'm obviously doing something wrong, and probably something quite basic, but i really can't see what it is. Any ideas would be very much appreciated.

  • UnderDogUnderDog Moderator
    @BangTheBore : Open a new thread and specify "insert duplicate key"
    We need to know exactly which duplicate key etc.
    Also, there's something wrong with the versions you're mentioning.
    Current version will be 2.0.18 and not
  • You're forgetting to take that saved conf.php file and put it back into the /conf/ folder after you upload all the goodies BEFORE your run the upgrade script at "".

    You backed up the conf.php file, now you gotta put it back into the /conf/ folder BEFORE you run the upgrade script. or the upgrade won't know what database you're pointing to and what database to make the changes to.
  • I can't use URL re-writting because I'm using IIS. Can someone please provide the non-URL re-writting URL to access the structure AND run it?

    I already know that I can hit the page for the structure by going here: /?p=/utility/structure

    However, clicking the button also uses URL re-writting, so I need that URL in the normal URL format as well.

  • TimTim Lord of Servers Vanilla Staff
    Turn off Garden.RewriteUrls in your config file and Vanilla will stop making buttons and links with rewritten forms.

    Vanilla Forums Senior Developer [GitHub, Twitter,]

  • I already know that I can hit the page for the structure by going here: /?p=/utility/structure
    Oh my GOD! THANKS!
    I had no idea that worked as well
    Because it didn't work as forum/utility/structure
    Please, change the update tips to add this!!!

    Also... my forum is still not working. I switched off the Vanilla app (to try what happened, with version xxxx.17), I tried to update to xxx.18b4 (as I read somewhere in this forum), and then, after the "Update success" is still giving me the same fatal error message:
    Fatal error: Class 'CategoryModel' not found in /home/axxxxxxx/public_html/forum/applications/vanilla/settings/structure.php on line 65

    Thanks for reading!

    If you altered vanilla images with your own, save your images file too!
    Also any files you customised, such as veiws, default master.php etc.
    might be safer to save your entire forum appl folder somewhere first, then upload the new version, and replace files from your original. (be sure to rename your original to something else to avoid accidental overwrite and confusion.
  • LincolnLincoln Community Instigator Vanilla Staff
    @camo You should be making your image changes in your own theme. That'll stop you from accidentally overwriting them during an upgrade.

    Sr Developer at Vanilla Forums [GitHub, Twitter]

  • when its stable version is going to release ???
  • Help! I upgraded to the latest version and now I cannot open the discussions. I followed all the instructions in the earlier part of this thread including the update and structure portions with success. Everything in the dashboard is working fine, but the discussion threads themselves are no longer opening. Anyone have any suggestions or should I just roll the whole thing back?
This discussion has been closed.