Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Vanilla 2.0.18 RC2 released

LincolnLincoln Community Instigator Vanilla Staff
edited October 2011 in Blog
This is NOT a stable release. BACKUP YOUR DATABASE AND CONFIG.PHP FILE BEFORE UPGRADING. This is a release candidate for testing purposes only. I skipped releasing RC1 because I had 1 more patch to pull and messed up the git tag. :)

Download it here (VIA GITHUB - Do not use the Addons section on this site currently).

Thanks to everyone who filed issues against beta 4! It was very much appreciated. Special thanks to jspautsch, sbenes, zamrih, and petitben for contributing fixes since beta 4 that made it into this release candidate.

Changes since 2.0.18b4:

  • Fixed issue where user's IP address was returned by API

  • Fixes drag-n-drop category organization

  • Fixes setting of the Homepage view in Dashboard

  • Fixes profile to not ask for old password if one was never set (via SSO)

  • Fixed issue where footer would be hidden when clicking "More discussions"

  • Enabled "Mark All Viewed" plugin in mobile

  • Fixed user meta data bug that could result in data loss

  • Fixed where advanced notification permissions weren't checked correctly

  • Fixed case where bookmarked discussion would not show in module

  • Fixed support for PHP 5.2 on Windows (fnmatch)

  • Fixes SignIn target

  • Changed default: Ability to view other members' private conversations is now 'off' and require adding Conversations.Moderation.Allow = TRUE to config and manually giving permission Conversations.Moderation.Manage to allowed roles.

  • Adds 'AfterActivityQuery' event

  • Turns off Embed by default

  • Adds translatable strings

  • Misc framework fixes

  • Adds some inline documentation

We'll do more release candidates if/as necessary.


Here's the usual details:
=======================

Reporting Issues

DO NOT REPORT ISSUES ON THE COMMUNITY FORUM

Please report all issues on the GitHub Issue Tracker. Remember to do a quick search through the issues to make sure your issue has not already been added or resolved.

Keeping track of new releases

You can follow our releases by pointing your favorite RSS reader at:
http://www.vanillaforums.org/addon/vanilla-core/follow.rss
This feed will automatically update whenever we release a new version of Vanilla Core.

Troubleshooting the Vanilla 2 Installation

If you run into any issues during the installation, you may see the "Bonk" error screen. In order to get past this screen, you can add the following line to your conf/config.php file:
$Configuration['Garden']['Debug'] = TRUE;

This will show you a more detailed screen of information about the actual problem you've encountered. Please include this information when reporting issues (copy & paste exact errors, please).

Upgrading Vanilla 2.0 Forums


  1. Back up your database.

  2. Back up all of your existing files.

  3. Unarchive the new files and copy them over your existing files. Make sure that your hidden files (ie .htaccess) are copied to your server.

  4. Make sure the conf/config.php from your old version has been copied over to the new version.

  5. Delete all *.ini files in your cache/ folder

  6. Navigate to the page in your forum that updates your database: www.yourforum.com/utility/update (or www.yourforum.com/index.php?p=/utility/update)

  7. Visit your forum and test away!

For more help with upgrading, check out the Upgrade Documentation and the Upgrading Tips and Tricks thread.

Sr Developer at Vanilla Forums [GitHub, Twitter]

Tagged:
alexchen
«1

Comments

  • ShadowdareShadowdare π Moderator
    edited October 2011
    Thank you. The RC1 release on the addons page has a lot of problems that will render a forum useless if upgrading from beta. This is a good reminder to everyone who doesn't make backups to make backups.

    This release works excellently. Not a bad job at all. Thanks @Lincoln, @Tim, and others!
    alexchen
  • LincolnLincoln Community Instigator Vanilla Staff
    edited October 2011
    The "RC1" on the addons page actually gives you version 2.0.0 (first release), so yes that would be bad to use. Hence the GitHub link above while we continue to sort out the issues with the .org download. I didn't want the RC to get stale because of an unrelated problem.

    Sr Developer at Vanilla Forums [GitHub, Twitter]

  • LincolnLincoln Community Instigator Vanilla Staff
    @Shadowdare I made edits above to encourage backups and explicitly tell people to use the GitHub download. Thanks!

    Sr Developer at Vanilla Forums [GitHub, Twitter]

  • camocamo New
    edited October 2011
    @Lincoln
    This is just a question, not so much a problem, but I've discovered a strange thing after upgrading to RC2

    My file /forum/applications/dashboard/views/default.master.php,
    Has customisations that I added in header and footer.

    After upgrade, I saw that my customisations were gone i.e a second logo & links next to the logo.

    So I go and upload my original file, (overwrite) which I saved, that has these customisations, and sure enough, my customisations are back, looking great, BUT.....

    I go to the file again to make a change and discover the file is the default file, sans customisations, despite the customisations still being evident on the forum.

    How is this so? how can I edit my file now, unless I edit my original and upload/overwrite again.

    I just find this very strange, please comment? :)

    You can see my customisations remain

    http://www.camosreptiles.com.au/forum/index.php?p=/

    but this is my file !!!???
    <?php echo '<?xml version="1.0" encoding="utf-8"?>'; ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">


    <?php $this->RenderAsset('Head'); ?>

    " class="<?php echo $this->CssClass; ?>">



    "><?php echo Gdn_Theme::Logo(); ?>
    <?php
    $Session = Gdn::Session();
    if ($this->Menu) {
    $this->Menu->AddLink('Dashboard', T('Dashboard'), '/dashboard/settings', array('Garden.Settings.Manage'));
    // $this->Menu->AddLink('Dashboard', T('Users'), '/user/browse', array('Garden.Users.Add', 'Garden.Users.Edit', 'Garden.Users.Delete'));
    $this->Menu->AddLink('Activity', T('Activity'), '/activity');
    if ($Session->IsValid()) {
    $Name = $Session->User->Name;
    $CountNotifications = $Session->User->CountNotifications;
    if (is_numeric($CountNotifications) && $CountNotifications > 0)
    $Name .= ' '.$CountNotifications.'';

    if (urlencode($Session->User->Name) == $Session->User->Name)
    $ProfileSlug = $Session->User->Name;
    else
    $ProfileSlug = $Session->UserID.'/'.urlencode($Session->User->Name);
    $this->Menu->AddLink('User', $Name, '/profile/'.$ProfileSlug, array('Garden.SignIn.Allow'), array('class' => 'UserNotifications'));
    $this->Menu->AddLink('SignOut', T('Sign Out'), SignOutUrl(), FALSE, array('class' => 'NonTab SignOut'));
    } else {
    $Attribs = array();
    if (SignInPopup() && strpos(Gdn::Request()->Url(), 'entry') === FALSE)
    $Attribs['class'] = 'SignInPopup';

    $this->Menu->AddLink('Entry', T('Sign In'), SignInUrl($this->SelfUrl), FALSE, array('class' => 'NonTab'), $Attribs);
    }
    echo $this->Menu->ToString();
    }
    ?>
    <?php
    $Form = Gdn::Factory('Form');
    $Form->InputPrefix = '';
    echo
    $Form->Open(array('action' => Url('/search'), 'method' => 'get')),
    $Form->TextBox('Search'),
    $Form->Button('Go', array('Name' => '')),
    $Form->Close();
    ?>



    <?php $this->RenderAsset('Content'); ?>
    <?php $this->RenderAsset('Panel'); ?>


    <?php
    $this->RenderAsset('Foot');
    echo Wrap(Anchor(T('Powered by Vanilla'), C('Garden.VanillaUrl')), 'div');
    ?>


    <?php $this->FireEvent('AfterBody'); ?>


  • I have drag-n-drop category organization problem with ie9 firefox 6.X and chrome
    (it's ok on rc1) so I can't create parent category
  • Anyone else found, that after updating from the current stable version to this, that if they try to set the email confirmation role, it doesn't list the Confirm Email role in the selection box? I had to manually add the id of the role to the config file to set it correctly.

    This doesn't happen with a clean install though.
  • @Dru I upgraded from 2.0.18b4 to this but same thing yeah!
  • ToddTodd Chief Product Officer Vanilla Staff
    edited October 2011
    @Dru, give the email confirmation role sign in permission.

    @camo, You can still see your theme because the Smarty creates a php version of the file in your /cache folder. I really recommend you make your customizations in a theme. It's not that hard. Check out the quick start.
  • camocamo New
    edited October 2011
    @Todd

    done! Thankyou :)

    you said "@Dru, give the email confirmation role sign in permission."

    I want them to be 'applicant' until confirm Email. "applicant' & Guest' are limited to 'view'

    How do I give 'Applicant' role sign in permission so it appears in the dropdown?
  • DruDru
    edited October 2011
    @Todd Is there a way to give the email confirmation role that ability without having to manually edit the database? (Not that I mind, just curious if it's something that will be added to the ui). It's stored in the db as a role which can't have sessions so there's no option to add the sign in permission to that role.
  • ToddTodd Chief Product Officer Vanilla Staff
    You can give the email confirmation role sign in permission in your dashboard under roles & permissions.
  • edited October 2011
    Some css issues fix:
    open
    applications/dashboard/views/activity/all.php
    search
    <li class="Active"><?php echo Anchor(T('Recent Activity'), 'activity'); ?></li>
    replace with
    <li class="Active"><?php echo Anchor(T('Recent Activity'), 'activity', 'TabLink'); ?></li>

    open
    applications/dashboard/views/activity/item.php
    search
    <li class="Active"><?php echo Anchor(T('Activity Item'), 'activity'); ?></li>
    replace with
    <li class="Active"><?php echo Anchor(T('Activity Item'), 'activity', 'TabLink'); ?></li>

    create custom css file and paste this:
    .MorePager a,
    .MorePager a:link,
    .MorePager a:hover,
    .MorePager a:active,
    .MorePager a:visited {
    margin: 0;
    border: 1px solid #abdafb;
    border-radius: 3px;
    -moz-border-radius: 3px;
    -webkit-border-radius: 3px;
    background: #bbe2f7;
    display: inline;
    font-weight: bold;
    color: #1e79a7;
    text-decoration: none;
    padding: 5px 10px;
    line-height: 2.6;
    white-space: nowrap;
    }


    :)
  • camocamo New
    edited October 2011
    @Todd you said...
    You can give the email confirmation role sign in permission in your dashboard under roles & permissions.
    yet the does not seem to be such option???
  • @draghetto My activity page looks ok already, whats the fix do? Also with the pager, mine are a bit lengthy, how many are supposed to show?

    http://www.camosreptiles.com.au/forum/index.php?p=/activity
  • ToddTodd Chief Product Officer Vanilla Staff
    edited October 2011
    @camo, What option can't you find? Roles & Permissions? The sign in permission? What? Come on, put a little effort into your questions.
  • camocamo New
    edited October 2011
    @Todd,

    There is no check box to give sign in permission dude! Put a little effort into your answers, your pretty vague! Your supposed to be the expert right? Don't get pissed off at me because you give vague offhand and unhelpful answers, we're not all vanilla experts!

    Under Edit Confirm Email... wheres 'sign in permission' ?

    image
  • UnderDogUnderDog Moderator
    edited October 2011
    Put a little effort into your answers, your pretty vague! Your supposed to be the expert right?
    STOP! Read The private message I sent you
    edit PM sent after camo looked in his inbox :-S

  • My Inbox says empty UnderDog ???
  • @draghetto My activity page looks ok already, whats the fix do?
    Recent Activity looks like a link but it is a tab... With fix it returned to be a tab :)
    I hope this issues are corrented in 2.0.18 final :)
  • This morepager css should go in theme custom css? How many activity per page? mine seems to just add, e.g no (more) link

    Here I have 17 http://www.camosreptiles.com.au/forum/index.php?p=/activity
  • Anyone else found, that after updating from the current stable version to this, that if they try to set the email confirmation role, it doesn't list the Confirm Email role in the selection box? I had to manually add the id of the role to the config file to set it correctly.

    This doesn't happen with a clean install though.
    I confirm I didn't get the role either while upgrading. I will try a clean install now, but just in case... How do you add it role manually to the database?
  • Still waiting to find out too. I tried a few things, in

    /conf/config-defaults.php

    I found

    $Configuration['Garden']['Registration']['ConfirmEmail'] = FALSE;
    $Configuration['Garden']['Registration']['ConfirmEmailRole'] = 4;

    I changed the first to 'TRUE' The Role to '3' (it says Member is 4 so presumabley , 'applicant' would be '3'

    Then went to register in dashboard and clicked confirm email, it still only had 'Member', 'moderator', & Admin as choices, so I tried Member, created an account, and was signed in instantly and able to post instantly.

    It did pop a system message saying 'You must confirm your email' BUT, it still let me post, whats the point? I presumed 'confirm email' meant you couldnt do anything, UNTIL, you confirmed your email?
  • camocamo New
    edited October 2011
    OK second try, In roles&permissions, I created a new role called 'New'
    The only permissions I allowed were 'sign in' as suggested by @Todd and 'veiw discussions'.

    Under Registration, I tick the 'Confirm email, and 'New' appears in the dropdown.
    Saved!

    As before, Im instantly signed in and instantly able to post,. Do get sys message to confirm email.

    Why was I signed in instantly and able to post instantly BEFORE confirming the email?

    @Todd, did you mean 'DONT' give email confirmation role sign in permission ?

    Does anything actually happen if they DONT confirm email?
  • lucluc ✭✭
    On vf.org, I don't have any "x new messages" on discussion anymore (Chrome 15/Windows). Same thing with SR Iron 13/Windows at work.

    It doesn't help to what I have read or not :), and where I may answer some questions.
  • @camo I achieved that desired result on .18b2 only. Maybe the programmers could take something from there. :)

    The idea is to remove the permission to sign in to those who haven't confirmed their email yet. It worked for me, it even stopped a few Xrummers.
  • LincolnLincoln Community Instigator Vanilla Staff
    @luc @UnderDog That's an unrelated issue with the vf.org theme that'll hopefully get sorted soon.

    Sr Developer at Vanilla Forums [GitHub, Twitter]

  • When is 2.0.18 hitting the streets?
  • LincolnLincoln Community Instigator Vanilla Staff
    @arpowers By the end of the month (probably - no promises)

    Sr Developer at Vanilla Forums [GitHub, Twitter]

«1
This discussion has been closed.