Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter
Support for Vanilla Forums Cloud product

In this Discussion

Follow Us


Can't get proxy connect to work

edited December 2011 in Questions

Don't know where I've gone wrong, but I installed Vanilla 2, WordPress 3.3 and PorxyConnect. But If I activate the proxy connect authenticator. It shows a empty page at login, and I get locked out of wordpress.

Any idea what is wrong here?

Tagged:

Best Answers

  • ToddTodd Chief Product Officer Vanilla Staff
    Answer ✓

    The most important thing is your cookie domain. You should examine your cookies in your browser and make sure that your wordpress cookies and your Vanilla cookies have the same domain.

  • ToddTodd Chief Product Officer Vanilla Staff
    edited December 2011 Answer ✓

    Okay Vanilla sets a cookie too and if you don't see it then either:

    a) You aren't browsing to Vanilla when you do this test.
    b) Vanilla has the wrong cookie domain and it doesn't have permission to write the cookie on your site.

    ProxyConnect has a place to specify your cookie domain. Make sure it's .golfclub-stippelberg.nl.

  • ToddTodd Chief Product Officer Vanilla Staff
    Answer ✓

    I really don't know what's going on here. Here are some other points:

    1. You really need to have curl enabled. We've made this requirement more clear in recent releases of ProxyRequest.
    2. Your host may not allow the curl requests that we make during ProxyRequest.
    3. The most recent version of ProxyRequest does have a test page. Make sure it checks out there.
    4. We are releasing a newer WordPress plugin shortly that will not use ProxyRequest, but rather jsConnect.
  • ToddTodd Chief Product Officer Vanilla Staff
    Answer ✓

    It looks like you have everything setup correctly. Try the following.

    1. Make sure you are signed in to Wordpress.
    2. Browse to /entry/land in Vanilla. This will force Vanilla to recheck the SSO.
  • ToddTodd Chief Product Officer Vanilla Staff
    Answer ✓

    I notice your cookie domains are not the same. One is .golfclub-stippelberg.nl and one is golfclub-stippelberg.nl.

  • ToddTodd Chief Product Officer Vanilla Staff
    Answer ✓

    Additionally, make sure that your default roles are set up properly and that they have permission to sign in. Sign in to the admin account you made Vanilla with and see where your user is and what role they have. If that role does not have permission to sign in then you'll have a problem.

  • ToddTodd Chief Product Officer Vanilla Staff
    Answer ✓

    Check to see if there are any users in Vanilla, not Wordpress. See what roles they have and if they have permission. Sign in through /entry/password and look at the users.

  • ToddTodd Chief Product Officer Vanilla Staff
    Answer ✓

    Okay listen. It looks like you have something going wrong and it's really beyond the scope of community support to solve it.

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    Answer ✓

    i had configured proxy connect on my localhost and just took me 5 mins without any problems signing in or anything. just followed the steps :)

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    edited December 2011 Answer ✓

    :) can you try reinstalling everything or it will be too difficult to do????? i had tried everything localhost before going live with anything like that

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    Answer ✓

    i mean installing wordpress and vanilla and the proxy connect - mean starting the whole process once again

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    Answer ✓

    oh okie then its really hard

Answers

  • O.K. managed to install i manualy, it tests SUCCESFULL. When I login Vanilla, it only recognizes my admin account. And login in wordpress does nothing.. (i.e. no login)

    I'm stuck!

  • ToddTodd Chief Product Officer Vanilla Staff

    Proxy connect has a lot of documentation. You need to make sure you read through it and make sure you have everything set up first. Making sure your cookie domains and paths are correct is especially important.

  • edited December 2011

    O.K. have read quite some docs today regarding this... and it seems that I'm not smart enough to understand them. Made sure everything is correct at no avail.

  • edited December 2011

    Made a little progress...

    Now I'm still able to log into wordpress when Vanilla Proxyconnect is activated.

    It still does not log any user into vanilla.

    Verification tests in vanilla still give SUCCESFULL, as they did before. However no new users get created.

    Now when I log into vanilla, I get redirected to the wordpress login, return to vanilla.... that's it. Logged into WordPress not logged into Vanilla, and no new user made. I end on the page http://golfclub-stippelberg.nl/vanilla/entry/handshake/proxy (i.e. login screen vanilla)

  • edited December 2011

    Do I need to have Vanilla in a special place in regard to Wordpress? I now have them in: - mydomain.nl/wp - mydomain.nl/vanilla

    My Wordpress site address - mydomain.nl

  • Hi Todd...

    Thanks for the response... the only cookie I find in safari is [golfclub-stippelberg.nl]. I have both plugins [.golfclub-stippelberg.nl] for the cookie domain.

  • edited December 2011

    Removed all cookies and looked in Firefox:

    I have a VanillaProxy cookie A wordpress_... and a wordpress_logged_in_...

    All have [.golfclub-stippelberg.nl] as domain.

    Both pluggins have this domain specified as cookie domain.

    I really don't how how I can verify if vanilla has permission to write the cookie on my site, other than finding it in my browser.

    Is there anything in my htaccess file that can interfere?

    (IfModule mod_rewrite.c)
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    (/IfModule)
    
    # BEGIN WordPress
    (IfModule mod_rewrite.c)
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    (/IfModule)
    
    # END WordPress
    
  • edited December 2011

    1-Curl installed and active

    curl

    cURL support enabled cURL Information libcurl/7.21.6 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

    2-I can't tell (asked my ISP, info is pending)

    3-Checked and double checked

    Make sure you are logged in to http://golfclub-stippelberg.nl, then press 'Test!'. Remote Response UniqueID=2 Name=Webmaster Email=webmaster@golfclub-stippelberg.nl TransientKey=a36053b176 DateOfBirth= Gender=Male UniqueID 2 Name Webmaster Email webmaster@golfclub-stippelberg.nl TransientKey a36053b176 DateOfBirth Gender Male Decoded Response Email webmaster@golfclub-stippelberg.nl UniqueID 2 Name Webmaster TransientKey a36053b176 TEST SUCCESSFUL You are logged in as Webmaster at http://golfclub-stippelberg.nl

    4-Looking forward to it ;-)

  • O.K. done..

    It is taking me to http://golfclub-stippelberg.nl/vanilla/discussions

    Not logged in Vanilla.

    I'm logged into wordpress, you can check: http://golfclub-stippelberg.nl/vanilla/entry/land

  • edited December 2011

    I'm baffled... The wordpress_... and wordpress_logged_in_... cookies in my browser have Domain: .golfclub-stippelberg.nl

    I've got a few wordpress cookies with Host: golfclub-stippelberg.nl but no others with Domain: golf club-stippelberg.nl

  • edited December 2011

    I'm using the standard roles in wordpress, and I've been testing with members and Admin. The only user in vanilla is the admin.

  • edited December 2011

    About the cookie domains.... is there any way I can change those golfclub-stippelberg.nl to .golfclub-stippelberg.nl

    Putting: define('COOKIE_DOMAIN', '.golfclub-stippelberg.nl'); in wp-config.php still does not log me into vanilla.

  • One user: AdminJack jackey@melisgs.nl Administrator 12 December 18:42 95.97.101.31

  • Thanks for trying Tod!

    Will put this to rest and seek out other forum options.

  • You're a happy camper then... kudos!

  • What do you mean with everything...

  • No option to re-install wordpress. I'm running a 1000+ user base website with no issues. Vanilla I will trash anyway, that would not be a problem.

  • Thanks anyway... I'm fed up with this cookie cr*p anyway. Let's probe out Simple-Press!

Sign In or Register to comment.